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前

　
言

高校教学包括理论教学和实践教学两部分。 理论教学的任务主要是传授知

识，教学方法主要是在一定范围内进行教师讲课和课堂讨论。 实践教学的任务主

要是培养能力，教学方法主要是在教师的指导下进行各种验证性、设计性实验，开
设各种课程，开展专业性和综合性的社会实践。 高等教育由精英教育向大众教育

演进后，在人才培养方面，为了实现传授知识、培养能力、提高质量的统一目标，在
注重理论教学的同时，开始赋予实践教学新的使命，把实践教学推向了一个新的发

展阶段。 事实证明，只有实践教学才能验证知识，消化和巩固知识；只有实践教学

才能培养动手能力，形成专业素养；只有实践教学才能激发创新思维，增强创新意

识，增强创新能力。 因此，在我国现阶段，无论是以培养应用型人才为主的教学型

大学，还是以培养研究型人才为主的研究型大学，实践教学都是教学的重要组成部

分。
计量经济学经过 ７０ 多年的发展，已经成为一门独立的应用经济学学科。 研究

和熟练运用计量经济学分析方法，对培养学生分析经济问题的能力，提高科研质量

至关重要。 １９９８ 年 ７ 月，教育部经济学教学指导委员会将“计量经济学”作为高校

经济学各专业的核心课程之一。 ２０ 多年来，国内高校关于“计量经济学”教学改革

的探索与实践，已成为经济教育教学改革的重要内容之一。
计量经济学课程非常实用。 其教学的主要目的是培养学生应用分析的能力，

教学生如何在计算机软件的帮助下，通过建立计量经济模型，定量地分析和解决实

际经济问题。 ＥＶｉｅｗｓ 是当今世界上最流行的经济计量软件之一，它具有数据处理、
映射、统计分析、回归建模分析、预测、时间序列（ＡＲＭＡ）模型分析等功能，是学习

计量经济学和进行计量分析的重要工具。 用计量经济学分析实际问题不仅需要计

量经济学的坚实理论基础和使用 ＥＶｉｅｗｓ 软件的基本技能，还需要一定的实践经验

和创新能力。 因此，重视教学实践，加强实验课和计算机实习显得尤为重要。 近年

来，我国陆续出版了一批高质量的计量经济学理论教材，但缺乏配套的实验教材，
影响了计量经济学方法的教学实践。 实验教材不仅要具有实验指导作用，而且要

突出培养学生的实践能力和创新能力。
从经济管理专业的学科属性出发，按照培养高素质人才的要求，参考理论教学

的体系和内容，我们编写了这本《计量经济学实验教程》。 在实验内容的编排上，切
入必要的理论知识基础，进行 ＥＶｉｅｗｓ 的基本操作练习，从运用经典的计量经济学

方法和实践，到运用非经典的计量经济学方法，最后通过综合实验案例对经济热点

问题进行分析。 各实践环节紧密相连，对知识的理解和掌握由低级向高级发展。
本实验教程主要由工具篇、基础篇和综合篇三个部分组成。 工具篇主要是对实验

用软件及数据获取方式的介绍。 基础篇是以理论知识为基础，从分析思路、操作步

骤和实证结论等方面进行阐述，包括一元回归模型、多元线性回归模型、多重共线



性、异方差、自相关、滞后变量模型、时间序列模型等多个实验，将 ＥＶｉｅｗｓ 软件应用

到案例中与理论知识进行结合，旨在培养和提高学生的应用技能，使理论学习与实

践分析相结合。 在基础实验的基础上，三个综合实验生动地展示了计量知识的综

合应用，提高和升华了知识点在计量经济中的实际应用。 在综合实验中，学生可以

很容易地形成完整的计量学习知识链，更容易掌握计量分析所需的知识，对实际问

题进行计量分析，撰写实证论文。
本书可作为高等学校经济、管理类专业本科教材，也可供具有一定经济学、数

学、统计学基础的经济、管理、金融类专业工作人员使用和参考。
本书在编写过程中，得到了电子科技大学出版社的关心和支持。 本书的编辑

为本书的出版付出了辛勤的劳动，我们在此表示诚挚的感谢。
由于编者水平有限，错误和疏漏是不可避免的，我们真诚地欢迎同行专家和读

者批评和指正，并提供有价值的意见。
编　 者
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1
CHAPTER

第1章

EViews软件简介

学习目标

  通过本章的学习,对EViews的用途和如何运行该软件有个初步的了解,认识EViews窗口的主要构

成部分:标题栏、主菜单、命令窗口、状态栏和工作区。

内容提要

  1.EViews的发展历史。

2.EViews的特点。

3.EViews的主要功能。

4.启动EViews的多种方法。

5.认识EViews窗口的基本组成部分。

6.学会使用EViews帮助资源。

1.1 什么是EViews

EViews(EconometricViews)是美国QMS(QuantitativeMicroSoftware)公司开发的

基于 Windows平台下提供复杂的数据分析、回归和预测工具的经济计量分析软件,EViews
前身是DOS操作系统下的MicroTSP软件,于1981年首次发布。EViews可用的领域包括:
科学分析和评估、财务分析、宏观经济预测、模拟、销售预测和成本分析。

【应用领域】

■ 应用经济计量学 ■ 总体经济的研究和预测

■ 销售预测 ■ 财务分析

■ 成本分析和预测 ■ 蒙特卡罗模拟

■ 经济模型的估计和仿真 ■ 利率与外汇预测

EViews的主要功能是对经济学领域的回归分析与预测(regressionandforecasting)、时
间序列(Timeseries)以及横截面数据(cross sectionaldata)分析等。与其他统计软件(如

SAS、SPSS等)相比,EViews功能优势是回归分析与预测。EViews提供了从键盘或磁盘文

件输入数据序列、从现有序列创建新序列、显示和打印序列以及对序列之间关系进行统计分

析的便捷可视化方法。EViews利用了现代 Windows软件的视觉特性,用户可以用鼠标进行

标准的 Windows菜单和对话框的操作。

1.1.1 EViews发展历史

EViews全称为EconometricViews,直译为计量经济学观察,通常称为计量经济学软

件包。它的本意是对社会经济关系与经济活动的数量规律,采用计量经济学方法与技术进
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行 “观察”。计量经济学研究的核心是设计模型、收集资料、估计模型、检验模型、应用模

型 (结构分析、经济预测、政策评价),EViews是完成上述任务比较得力的必不可少的工

具。正是由于EViews等计量经济学软件包的出现,使计量经济学取得了长足的进步,发

展成为一门较为实用与严谨的经济学科。

EViews是专门为大型机构开发的,用以处理时间序列数据的时间序列软件包的新版

本。1981年MicroTSP面世,1994年,QMS(QuantitativeMicroSoftware)在MicroTSP
基础上分别推出了V1.0、V2.0、V3.0、V3.1、V4.0、V5.0和V6.0、V7.0、V8.0、V9.0
等版本。虽然EViews是经济学家开发的,而且主要用于经济学领域,但是从软件包的设

计来看,EViews的运用领域并不局限于处理经济时间序列,即使是跨部门的大型项目,也

可以采用EViews进行处理。本教材以EViews8.0版本为基础进行讲解。

1.1.2 EViews特点

EViews在 Windows环境下运行,与MicroTSP相比,它的界面更友好,功能更强大,
使得原本较为复杂的数据分析过程变得易学易用,被视为用于计量经济学教学和科研工作

的流行软件。

1.便捷性

EViews提供便利的从键盘。磁盘文件得到数据的方法,可从已有的数据得到新的数

据,并能显示和打印有关数据,还可以做数据序列的统计分析和相关分析。

2.可视化

EViews得益于 Windows的可视的特点,EViews能通过标准的 Windows菜单和对话

框,用鼠标选择操作,并且能通过标准的 Windows技术来使用显示于窗口中的结果。

3.程序化

用户可以利用EViews的强大的命令功能和它的大量程序处理语言,进入命令窗口修

改命令。用户可以将计算工作的一系列操作建立成相应的计算程序并储存,从而可以通过

直接运行程序来完成复杂的计算工作。

1.1.3 EViews主要功能

EViews引入了流行的对象概念,操作灵活简便,数据管理简单方便,并可采用多种操

作方式进行各种计量分析和统计分析,其主要功能有:
(1)采用统一的方式管理数据,通过对象、视图和过程实现对数据的各种操作;
(2)输入、扩展和修改时间序列数据或截面数据,依据已有序列按任意复杂的公式生

成新的序列;
(3)计算描述统计量:相关系数、协方差、自相关系数、互相关系数和直方图;
(4)进行t检验、方差分析、协整检验、Granger因果检验;
(5)执行普通最小二乘法、带有自回归校正的最小二乘法、两阶段最小二乘法和三阶

段最小二乘法、非线性最小二乘法、广义矩估计法、ARCH模型估计法等;
(6)对二择一决策模型进行Probit、Logit和Gompit估计;
(7)对联立方程进行线性和非线性的估计;
(8)估计和分析向量自回归系统;
(9)多项式分布滞后模型的估计;
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(10)回归方程的预测;
(11)模型的求解和模拟;
(12)数据库管理;
(13)与外部软件进行数据交换。

1.2 EViews软件的启动和退出

1.2.1 EViews软件的启动

在 Windows状态下,有以下几种启动EViews的方法。
【方法一】单击桌面任务栏中的 “开始”按钮,进入 “所有程序”,选择进入 “EViews

程序组”,选择EViews,双击即可打开。
【方法二】双击桌面上的EViews程序图标即可进入EViews软件应用界面。
【方法三】如果已经建有EViews工作文件 (EViewsWorkfile)、数据文件 (Database)

或程序文件 (Program),双击工作文件、数据文件或程序文件即可进入EViews软件应用

界面。

1.2.2 EViews软件的退出

在关闭前应保存当前文件,可在主菜单上选择 “File/Save”保存为已存在文件名,或

“File/SaveAs”保存为新文件名。退出EViews软件有以下几种方法。
【方法一】在主菜单上选择 “File”→ “Close”,或 “File”→ “Exit”,或按 “Alt+

F4”键来关闭EViews窗口。
【方法二】单击EViews窗口右上角的关闭按钮或工作文件窗口右上角的关闭按钮,或

双击EViews窗口左上角的EViews符号选择 “Close”来关闭窗口。
【方法三】单击EViews的工作文件窗口 (EViewsWorkfile)左上角的控制菜单按钮,

然后选择 “Close”来关闭窗口。
在关闭时,EViews总会发出警告,提醒用户将那些尚未保存的文件保存到磁盘文件中。

1.3 EViews软件的基本认识

启动EViews软件后可进入软件应用界面。EViews窗口由标题栏、主菜单、命令窗

口、状态栏和工作区五个部分组成,如图1 1所示。

1.3.1 标题栏

标题栏位于EViews主窗口的最上方,标记有 “EViews”字样。标题栏左边是控制框、
右边是控制按钮,有 “最小化”“最大化 (或还原)”“关闭”三个按钮。当EViews是 Win-
dows中的活动程序时,标题栏的颜色和强度与其他窗口不同,标题栏的颜色会随着操作变化

而变化。例如,当EViews工作区窗口处于活动状态时,工作区窗口的标题栏的颜色是蓝色的

(或者说颜色加深);当其他窗口处于活动状态时,它的颜色会变成灰色的 (或者说颜色变
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图1 1 EViews窗口

暗)。如果另一个程序处于活动状态,则可以通过单击EViews工作区窗口的任何位置或使用

“Alt+Tab”键在应用程序之间切换,使EViews工作区窗口回到激活状态。

1.3.2 主菜单

主菜单位于标题栏下方,主菜单中排列着按照功能划分的9个主菜单选项,分别是:

File、Edit、Object、View、Proc、Quick、Options、Window、Help,9个主菜单选项提

供的主要功能如下。

File可以实现有关文件 (工作文件、数据库、Eviews程序等)的常规操作,如图1 2
所示。

图1 2 File常规操作窗口

其中:

New (建立):建立新的工作文件、程序文件和文本文件。

Open (打开):打开已有的工作文件、程序文件和文本文件。

Save(保存):保 存 激 活 的 工 作 文 件、程 序 文 件 和 文 本 文 件。若 文 件 没 有 命 名,

EViews将要求用户对其命名。

—6—



SaveAs(另存为):不改变当前文件而另外生成一个文件并保存刚才修改过的内容。

Close(关闭):关闭激活的窗口。如果窗口打开的是工作文件、程序文件和文本文件,
它们将从内存中被清除。如果这些文件没有存盘,EViews将询问用户是否存盘。

Import(导入):将数据从其他文件中读入EViews。文件的类型可以是EViews数据

库、DRI数据库、文本文件、Lotus和Excel。从DRI、文本文件、Lotus和Excel导入数

据时,EViews将打开另一个对话框,询问数据的格式。

Export(导出):将数据写入EViews数据库、文本文件、Lotus和Excel。用户在选择

存储文件时,首先必须从工作文件中选择对象。

Print(打印):打印当前激活窗口的图形或表格。

PrintSetup (打印设置):控制打印选项。EViews将打开一个窗口,允许设置打印机

或将输出结果送入磁盘文件。

Run (运行):运行EViews程序 (program)文件。

Exit(退出):关闭所有窗口并退出EViews。EViews将提示用户保存所有未保存文件。
将光标移动到主菜单中的某个条目并单击鼠标左键,将出现一个下拉菜单,单击下拉

菜单中的条目可选择突出显示的项。比如 “New”菜单下包含 “Workfile” “Database”
“Program”“TextFile”。菜单中黑色的是可执行的项目,灰色的是暂时不可执行的无效项

目。如图1 3所示,在没有打开任何工作文件时, “Object”下拉菜单项 “NewObject”
“Name”就是灰色的。

图1 3 “Object”下拉菜单项

Exit包括了一些与 Windows其他程序操作命令相近的功能,如图1 4所示。

图1 4 “Edit”下拉菜单项

Undo(撤销):撤销最近一次的编辑。

Cut(剪切):删除选中部分并将其放入 Windows剪贴板。
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Copy (复制):将选中部分复制到 Windows剪贴板。

CopySpecial(特殊复制):EViews将出现一个对话框,供用户选择复制对象名称或对

象数据。

Paste(粘贴):将 Windows剪贴板中的内容放入指定位置。

PasteSpecial(特殊粘贴):EViews将出现一个对话框,供用户选择粘贴对象名称或对

象数据。

Delete(删除):删除选中部分。

Find (查找):在文本文件中查找字符串。

Replace(替代):在文本文件中替代字符串。

Next(查找下一个):查找下一个符合条件的字符串。

InsertTextFile(插入文本文件):向EViews中导入文本格式的数据文件。

Objects提供关于对象的基本操作。对象必须放在工作文件中,如图1 5所示。

图1 5 “Objects”的基本操作

NewObjects(建立新对象):建立一个新的EViews对象。

FetchfromDB (获取对象):把一个对象从磁盘中调入当前工作文件。

UpdatefromDB (更新对象):从对象文件中提取存储的对象用以更新当前对象。

StoretoDB (储存对象):将选择的对象储存在可保存如果选择了多个对象,一般需要

逐个输入。

Copyselected (复制):复制选择的对象。

Nameselected (命名):给选择的对象进行命名。

Deleteselected (删除):将选择的对象从当前工作文件中删除。

FreezeOutput(冻结当前视图):冻结对象的当前视图,并保存为一个新的对象。若

当前视图是一个图形,那么新对象将是一个图形对象。若为其他视图,新对象将是一个可

以编辑的表格对象。

Print(打印):打印激活窗口的当前视图。

ViewOptions(功能选择):改变当前对象的操作功能。

View和Procs二者的下拉菜单项目随当前窗口不同而改变,功能也随之变化,主要

涉及变量的多种查看方式和运算过程。例如,当前窗口为工作文件窗口,View功能键可以

选择特定的对象,以多窗口或单窗口打开所选对象等。如果序列对象为当前激活窗口,

View功能键就可以提供序列的各种不同的视图类型,如表格视图、折线图、相关图等。如

果一个方程对象为当前激活窗口,View功能键可以提供方程的设定形式、估计结果和协方

差矩阵等。

Quick下拉菜单主要提供一些简单常规用法的快速进入方式,如图1 6所示。
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图1 6 “Quick”下拉菜单

Sample(样本):改变或设置统计分析所使用的样本范围。在打开的对话框中需要输入

样本的起始期和终止期以及样本对象的名称。

GenerateSeries(生成序列):创建一个新的序列对象。在打开的对话框中输入新序列

的名称以及生成新序列的公式,并可以在对话框内改变默认的样本范围。

Show (显示):打开已选择的对象。如果没有选择对象,EViews将出现对话框提示输

入对象名称。

Graph (图形):生成图形对象。对话框会提示输入要生成图形的序列或组的名称以及

生成图形的类型。

EmptyGroup (打开空白序列组窗口):打开一个未命名的组对象的数据表格。

SeriesStatistics(单序列统计):对单个序列进行各种统计与计算并显示相应图形,包

括直方图、相关图、单位根检验、指数平滑、季节调整等。

GroupStatistics(序列组统计):对一个序列组进行各种不同的统计计算,其中的功能

有统计特征值、相关矩阵、相关图、交叉相关矩阵、协整检验等。

EstimateEquation (估计方程):建立并估计方程。EViews将弹出对话框提示设定方

程,并选择估计方法。

EstimateVAR (VAR估计):向量自回归估计。在弹出的对话框中可选择向量自回归

或误差修正模型,并进行相应的设定。

Options是系统参数设定选项。与一般应用软件相同,Eviews运行过程中的各种状

态,如窗口的显示模式、字体、图像、电子表格等都有默认的格式,用户可以根据需要选

择下拉菜单中的项目对一些默认格式进行修改,如图1 7所示。

图1 7 “Options”下拉菜单

GeneralOptions(常规选项):EViews将打开 “常规选项”对话框。此对话框分为多

个部分,包括主题风格、字体大小、页面布局、效果等。

GraphicsDefaults(图形选项):EViews将打开 “常规选项”对话框。此对话框为图

形首次创建时控制选项。

DatabaseRegistry (登记数据库):数据库是磁盘上以 “.edb”为扩展名的文件,用以

存储和管理EViews工作文件中所使用的对象。

EViewsAuto-Updatefrom Web (联网升级):EViews包含一个自动更新功能,可以
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自动检查新的更新,并安装任何可用的更新。

Windows提供多种在打开窗口种进行切换的方式,以及关闭所有对象 (CloseAll
Objects)或关闭所有窗口 (CloseAll)功能。带 “√”符号的选项是处于激活状态的窗口,
如图1 8所示。

图1 8 “Windows”下拉菜单激活状态的窗口

Help是Eviews的帮助选项。选择EviewsHelpTopics按照索引或目录方式在所有

帮助信息中查找所需项目,如图1 9所示。

图1 9 “Help”下拉菜单

EViewsHelpTopics(帮助主题):给出了帮助文件的内容目录,双击某一目录可以得

到进一步详细的内容,还可以在索引选项卡中输入关键字查找自己需要帮助的内容。

ReadMe(自我说明):给出了新版本的特征说明以及最近几次对软件的更新。

UsersGuide(用户指南):讲述怎样使用EViews进行研究工作。前几章讲授基本操

作,中间几章讲授基本的计量经济学方法,最后几章介绍高级方法。指南的绝大部分内容

都是在介绍采用鼠标图形界面方式操作EViews的方法。

Command&FunctionReference (命令与编程参考手册):提供了EViews命令的详

细、系统的信息,用户可以自行选择,是采用鼠标图形界面这种人机交互式工作模式,还

是学习编程技术,并采用命令语言使工作更为有效。

ObjectReference(对象参考):给出带链接形式的对象类型目录。点击某一对象类型

的名称可以得到对该对象类型的详细解释说明。

1.3.3 命令窗口

命令窗口位于主菜单栏下方的白色区域,在该窗口中输入EViews命令,按 “Enter”

—01—



键 (回车键)即可执行命令。命令窗口中的不断闪动的竖条称为插入点,它指示键盘键入

字符的位置。将插入点移至已经执行过的命令行,编辑命令窗口中已经存在的命令,按

“Enter”键将立即执行修改后的命令。若键入的命令超过了命令窗口显示的大小,窗口右

侧 (或下侧)就自动出现滚动条,通过上下滑动调节,以浏览已执行命令的各个部分。如

果想要查看最近30个命令的历史记录,按 “Ctrl+J”键后在弹出窗口中使用向上和向下箭

头选择所需的命令,然后按 “Enter”键将其添加到命令窗口,或者双击该命令。
如果发现命令窗口的默认大小太大或太小,无法满足需要,可以通过将光标放在命令

窗口的底部、按住鼠标按钮并向上或向下拖动窗口来调整命令窗口的大小。当命令窗口达

到所需大小时,释放鼠标按钮即可。若要在活动窗口和命令窗口之间切换,请按F5键。
命令窗口支持命令剪切和粘贴,以便用户可以轻松地在命令窗口、其他EViews文本

窗口和其他窗口程序之间移动文本。命令区域的内容也可以直接保存到文本文件中供以后

使用:单击窗口中的任何位置,确保命令窗口处于活动状态,然后从主菜单中选择

“File”→ “SaveAs”,即可将命令窗口的EViews命令以文本的形式保存下来以备下次调

用,如图1 10所示。

图1 10 EViews命令保存

如果输入的命令超出了命令窗口的大小,EViews会将该窗口转换为标准的可滚动窗

口。此时,只需使用滚动条或窗口右侧的上下箭头,即可查看以前执行的命令列表的各个

部分。用户可以将插入点移动到以前执行的命令,编辑现有命令,然后按 “Enter”键执行

已编辑的命令版本。如果想要查看最近30个命令的历史记录,按 “Ctrl+J”键后在弹出窗

口中,使用向上和向下箭头选择所需的命令,然后按 “Enter”键将其添加到命令窗口,或

者双击该命令。
如果发现命令窗口的默认大小太大或太小,无法满足需要,可以通过将光标放在命令

窗口的底部、按住鼠标按钮并向上或向下拖动窗口来调整命令窗口的大小。当命令窗口达

到所需大小时,释放鼠标按钮即可。

1.3.4 状态栏

状态栏位于窗口的最底端,它被分成四个部分,从左到右分别为:信息框、路径框、
当前数据库框和当前工作文件框。信息框有时提供EViews发送的状态消息,单击状态栏

最左边的方块可清除这些状态信息;路径框是寻找数据和程序的预设目录;当前数据库框

和当前工作文件框分别显示预设的数据库和工作文件的名称。

1.3.5 工作区

工作区位于EViews窗口的中间部分。EViews可显示多个目标窗口,这些窗口会相互
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重叠且当前活动窗口处于最上方,只有活动窗口的标题栏是深色的,即处于激活状态。当

需要的窗口被部分覆盖时,可单击该窗口的标题栏或该窗口的任何可见部分使该窗口处于

最上方;此外,还可通过单击 “Window”菜单,从中选择需要的窗口名称来直接选择窗

口。用户移动窗口可通过单击标题栏并拖拽窗口来完成,单击窗口右端底部的角落并拖拽

角落可改变窗口的大小。

EViews  启动与退出  标题栏  主菜单  命令窗口  状态栏  工作区
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  (1)EViews,EconometricViews(经济计量视图),是美国 QMS公司开发的运行

于 Windows环境下的经济计量分析软件,它引入了全新的面向对象概念,通过操作对

象实现各种计量分析功能。
(2)EViews软件功能很强,能够处理以时间序列为主的多种类型数据,进行包括

描述统计、回归分析、传统时间序列分析等基本数据分析以及建立条件异方差、向量自

回归等复杂的计量经济模型。
(3)EViews在 Windows环境下运行,与 MicroTSP相比,它的界面更友好,功能

更强大,使得原本较为复杂的数据分析过程变得易学易用,具有便捷性、可视化、程序

化特点。
(4)在 Windows状态下,有多种启动和退出EViews的方法。在关闭EViews时,

用户需确认是否将文件保存到磁盘文件中。
(5)启动EViews软件后可进入软件应用界面,EViews窗口由五个部分组成:标

题栏、主菜单、命令窗口、状态栏和工作区。EViews窗口的顶部是标题栏,标题栏左

边是控制框,右边是控制按钮,有 “最小化”“最大化 (或还原)”“关闭”三个按钮;
标题栏下面是菜单栏。菜单栏中排列着按照功能划分的9个主菜单选项,用鼠标单击任

意选项会出现不同的下拉菜单,显示该部分的具体功能;菜单栏下面是命令窗口,用户

可在光标位置用键盘输入各种Eviews命名,并按回车键执行该命令;命令窗口下面是

EViews的工作区窗口,操作过程中打开的各子窗口将在工作区内显示;EViews主窗口

的底部是状态栏,从左到右分别为:信息框、路径框、当前数据库框和当前工作文

件框。
(6)EViews提供内置帮助系统、操作手册和互联网资源在EViews网站的信息

区可以找到有关安装、使用及EViews以外的其他问题的答案。
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2
CHAPTER

第2章

EViews基本概念

学习目标

  通过本章的学习,要能初步了解EViews中的常用概念:序列、工作文件、对象、视图、组和数据

库文件等,并掌握工作文件的基本操作和针对一般对象的通用操作。

内容提要

  1.EViews中 “对象”的概念。

2.工作文件基础。

3.数据库基础。

4.一般对象操作基础。

2.1 EViews中常用概念

EViews为用户提供了基于 Windows平台的复杂的数据分析、回归及预测方法。通过

EViews能够快速从数据中获得统计关系,并根据这些关系进行分析、评价和预测。

2.1.1 序列 (Series)

从时空维度来看,可将计量经济学中应用的数据分三类。第一类是横截面数据 (Cross
sectionaldata)。横截面数据是指在某一时点收集的不同对象的数据。它对应同一时点上不同

空间 (对象)所组成的一维数据集合,研究的是某一时点上的某种经济现象,突出空间 (对
象)的差异。第二类是时间序列数据 (Time seriesdata)。时间序列数据是指对同一对象在

不同时间连续观察所取得的数据。它着眼于研究对象在时间顺序上的变化,寻找空间 (对象)
历时发展的规律。第三类是面板数据 (Paneldata)。面板数据,是截面数据与时间序列综合起

来的一种数据资源。在EViews中,横截面数据和时间序列数据都称为 “序列”。

EViews中数据频率分为日期型频率和非日期型频率两类。不规则的日期数据归入非日

期型数据类。对非日期型序列 (截面数据),须指明:“起始序号”为1,“终止序号”为序

列数据的最大个数。

2.1.2 工作文件 (Worlfile)

工作文件是EViews对象的集合。EViews中的大多数工作都涉及对象,它们包含在工

作文件中,因此用户使用经济计量学软件包之前,启动软件包以后必须首先在内存

(RAM)中建立工作文件,即在RAM中开辟处理数据的工作区。或者,从磁盘上加载一

个工作文件到内存。在用户与EViews软件的交互式处理过程中,工作文件一直保存在内

存中。工作文件中可以包括的对象有序列、组、方程、图形、系统、模型、系数向量等。
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2.1.3 对象 (Object)

EViews软件包使用术语 “对象”(Object)表明它已经向面向对象的设计思想前进了

一大步。EViews是围绕对象这个概念建立起来的。对象一词涉及可对其操作和建立的许多

项目,包括序列、方程、模型、系数和矩阵等数据对象和图形、表格和文本等非数据对象。
对象都放置在对象集合中,其中工作文件是最重要的对象集合。在用户与EViews会话期

间,用户正在使用的、被激活的窗口中的对象在屏幕上是可见的;而其他非激活窗口中的

对象要么是一个图标,要么是一个打开的窗口。双击图标可以使其变成窗口,也可以点击

窗口最小化按钮使窗口变成一个图标。

2.1.4 视图 (Views)

每个对象都具有一定的视图。通常意义下的对象具有属性、方法、函数和过程等,一

旦对象被激活,它的属性等就会表现出来。显然在EViews中,“视图”指的是对象可视的

一些属性。一个对象提供的用以对其自身属性进行查看和分析的窗口称为该对象的 “视
图”,大多数对象具有多种属性,从而具有多个 “视图”,即用户可以从多个窗口对该对象

的不同属性进行观察。例如,一个序列的视图既可以是图形,也可以是表或电子数据表,
还可以是描述统计量等综合计算的结果。

视图并不是孤立的,它是对应数据对象属性的表现。所以,当序列中的数据发生变更

时,该对象的图形视图将自动进行更新。
对象具有视图,与此同时视图也可生成对象。EViews允许用户将一个视图转化为一个

对象,EViews称这样生成的对象为视图的 “冻结”对象。当对应序列中的数据发展变化

时,冻结的图形将不再发生变化。EViews允许对冻结的视图进行各种各样的编辑并把它们

传送到其他软件中去。

2.1.5 组 (Group)

组是对象之一,组对象具有灵活、简便的特性。从本质上看,“组”是把若干序列合并

在一起构成的,以便对组内所有的序列同时使用一种方法进行操作。一个组可由若干序列

或若干其他的组构成。用户可利用组打开该组的各种视图。

1.组的作用

(1)通过组视图,从多个角度查看组内所有序列的数据;
(2)可以直接在组窗口中通过键盘输入和编辑数据。

2.组的特性

(1)组不是各个序列数据的一个拷贝。当用户改变属于某组的一个序列的数据时,在

组窗口中可以看到这些数据的新变化;
(2)如果删除一个序列,那么此时会看到该序列也从所属组中消失了;
(3)如果对组中某个序列改名,这个序列仍留在所属组中,但名称已被更改。

3.组具有的 “视图”
(1)组具有 “视图”,每个 “视图”又是以 “窗口”的形式出现的;
(2)组的标准视图是以电子数据表形式显示序列的窗口,表中序列都是按列排列的;
(3)组的其他 “视图”包括图形和描述性统计量等窗口。
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2.1.6 数据库文件 (DataBankFiles)

EViews允许用户在磁盘的某个目录下保存EViews产生的数据库文件。EViews的各

个对象都可以形成数据库文件,其扩展名指明了这是哪一类对象的数据库文件。常见的数

据库文件的扩展名及其对应类型见表2 1。
表2 1 数据库文件的扩展名及其对应类型

拓展名 对应类型

.db series

.dbe equation

.dbm matrix、vector或coefficient

.dbg graph

.dbr group

.dbt table

.dbl model

.dbs system

.dbv vectorautoregressiom

通过使用各个窗口上工具栏的按钮,可以进行对象的磁盘操作与管理:

①对数据文件进行储存 (Store);

②读取数据文件 (Fetch);

③删除数据文件 (Delete);

④数据文件重命名 (Rename)等操作。

2.2 EViews对象基础

EViews的核心就是对象。EViews中所有的数据信息都存储在对象中,对数据的操作

都可以通过查看其属性或使用其操作方法来实现。每个对象都包含与一个特定分析领域有

关的信息。与一个特定概念相关的对象被称为一种 “类型”,一个类型名被用来表示一类分

析。例如,一个序列对象中储存着各期观测值数据的有关信息。
对数据的操作可通过查看对象的属性或使用其操作方法来实现。与每类对象相关联的

是一系列视图 (Views)和过程 (Procedure),它们和对象中的信息一起使用。这种视图、
过程与对象中的数据的相关联被称为是面向对象的EViews设计。方程对象中包含着各种

与预测有关的信息,可以检测结果、做假设检验或做出预测,所有的这些工作只需对一个

方程对象操作就可实现。
不同对象包含着多种不同类型的信息。例如,序列对象、矩阵对象、向量对象等主要

包含数值方面的信息。相反,方程对象和系统对象包含方程或系统的完整的信息,除了包

含用来做估计的数据外,还包含估计的结果信息。图对象和表对象包含数值的、文本的和

格式的信息。因为对象中包含各种不同种类的数据,可以用不同的方法处理不同的对象。
例如,对一系列观测值求和或以方程的结果为基础做预测。EViews为此提供了常用的工具

即视图和过程,处理对象中的数据。
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EViews中与对象相关的概念有对象容器、对象类型。

2.2.1 对象容器 (ObjectContainers)

对象容器是用于保存和组织对象的,所有对象都必须存放在此。其本身也是一个对象,

EViews的对象容器有两种:工作文件 (Workfile)和数据库 (Database)。
工作文件是最重要的对象容器,进行任何分析的第一步就是建立一个新的工作文件或

打开一个已有的工作文件。工作文件创建或打开后就一直保存在内存中,这使得对工作文

件中的对象进行存取的速度更快。每个工作文件都具有特定的样本数据频率 (Frequency)
和范围 (Range)。

EViews工作文件 (Workfile)工具栏包括一些用来操作对象的功能键,如图2 1所

示。当工作文件窗口被激活时,所有这些功能都可以从主菜单中得到,但是使用工作文件

工具栏通常更简便一些。

图2 1 “EViews”工具栏

View (视图)提供选择对象的捷径,便于用户操作,可以用来改变对象窗口的视图

形式,可以显示为:电子表格形式、线性图、条形图以及一些描述统计与检验。下拉菜单

如图2 2所示。

图2 2 “View”下拉菜单

OpenSelected (选择打开):包括OpenOneWindow和OpenSparateWindows,其中

OpenOneWindow表示为在一个窗口中打开选择对象,OpenSparateWindows表示为选

择多个对象、并就每一个对象打开一个独立的窗口。

SelectAll(全选):选择特点类型的所有对象。

DeselectAll(撤销选择):撤销所有选择。

NameDisplay (显示名称):用来选择工作文件目录中的对象名称是以大写字母 (Up-
percase)显示还是以小写字母 (Lowercase)显示。

Procs(过程):提供选择对象的捷径,便于用户操作。对于一个序列来说,可调用的

过程有通过公式生成序列、季节调整、指数平滑等。下拉菜单如图2 3所示。
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图2 3 “Procs”下拉菜单

Object(对象):进行有关序列对象的存盘、命名、删除、拷贝和打印等。

Save(文件保存):等同于主菜单中的 “File”→ “Save”功能,即保存工作文件。

Freeze(冻结):可以以当前视图为冻结建立新的图形对象、表格对象或文本对象,
这样原序列发生变化时,新的图形或表格对象将不再发生变化,即便是关闭或删除元数据,
被冻结的对象仍然被保留在工作文件中。

Details+/- (详细信息):EViews将在标准工作文件显示格式和提供从每个对象的

标签中提取的附加信息的显示之间切换。

Show (显示):等同于主菜单中的 “Quick”→ “Show”功能。

Fetch (提取对象):等同于主菜单中 “Object”→ “Fetch”功能,即将磁盘上以文

件形式存储的对象调入当前工作文件中。

Store(储存):等同于主菜单中的 “Object”→ “Store”功能,即将所选对象以文件

形式储存至磁盘中。

Delete(删除):等同于主菜单中的 “Object”→ “Delete”功能,即从当前工作文件

中删除所选对象。

Genr(生成序列):等同于主菜单中的 “Quick”→ “GenerateSeries”功能。通过公

式生成一个新序列。

Sample(样本):等同于主菜单中的 “Quick”→ “Sample”功能。设置视图和统计

运算中观测值的范围。
数据库与工作文件不同,当存取数据库中的对象时,可以直接对保存在磁盘上的数据

库对象进行存取,无须将整个数据库装载到内存。数据库中的对象可以有不同的数据频率

和范围。数据库支持强大的查询功能,适用于管理大量数据。

2.2.2 对象类型 (Object)

对象用于保存计量经济分析所需信息。根据分析目的的不同,可分别使用不同类型的

对象。一类对象可以包含不止一种信息,比如方程对象,不仅包含预测方程的参数,还包

括一些特定的说明、参数估计的方差 协方差矩阵,以及相应的一系列统计说明。根据保存
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信息的不同,对象类型可分为数据对象和非数据对象。例如,序列、方程等为数据对象,
文本、图形等为非数据对象。

使用具体对象前,必须事先进行定义,即创建对象。用户可以用菜单或命令的方式进

行。EViews8.0常见的27种内置对象,如表2 2所示,可分别完成不同的分析功能,且

每一种对象类型都有一个固定的类型名称。根据保存信息的不同,对象类型可分为数据对

象和非数据对象。
表2 2 EViews对象

图表 对象类型名称及说明

 Series(序列):用于保存时间序列数据或截面数据

 Group (组):序列或者表达式的集合

 Scalar(标量):用于保存单个数值

 Equation (方程):用于单方程的估计、检验和预测等

 System (系统):用于联立方程估计和检验等

 Model(模型):用于联立方程的预测和模拟等

 Graph (图表):用于代表图形

 Matrix (矩阵):用于代表矩阵 (二维数组)

 Pool(数据池):用于面板数据 (包含时序和截面数据)的估计和检验等

 Sample(样本区间):用于定义样本区间

 Coef(系数向量):用于代表方程或系统的系数

 Sspace(状态空间);用于动态系统的估计、检验等

 SYM (SymmetricMatrix)(对称矩阵):用于代表对称矩阵

 Table(表格):表格

 Text(文本):文字

 VAR (向量自回归):用于向量自回归或误差修正模型

 Vector(列向量):用于代表列向量 (一维数组)

 SeriesAlpha(Alpha序列):字符型序列

 Logl(对数似然函数):用于极大似然估计

 Spool(储存池):能把图片和表格放在一起管理

 Valmap(值映射):将不易理解记忆的数值、代号或者编码映射为直观的说明文字

 Factor(因子):用于因子分析

 SeriesLink (序列链接):可以合并来自不同工作文件的信息

 UserObj(用户自定义对象)

对象中所保存的信息,除了数据以外,还有视图 (Views)和过程 (Procedure)。这种

把对象中的数据、对象的视图和对象的过程关联起来的做法称为 “面向对象的EViews设

计”。例如,方程对象中包含这各种与预测有关的信息,可以检测结果、做假设检验或做出

预测,所有的这些工作只需对一个方程对象进行有关操作即可实现。

①对象中的数据。不同对象中包含着多种不同类型的信息。例如,序列对象、矩阵对

象和向量对象等主要包含数值方面的信息;而方程对象和系统对象则包含方程或系统方面

的完整的信息,它们除了包含用来做估计的数据外,还包含估计的结果信息;图对象和表
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对象包含数值的、文本的和格式的信息。
因为对象中包含各种不同种类的数据,所以可以用不同的方法处理不同的对象。例如,

对一系列观测值求和或以方程的结果为基础做预测,EViews为此提供了常用的工具 (视图

和过程)来处理对象中的数据。

②对象的视图。对象的视图被显示在对象的窗口上。只要在对象窗口的工具栏中选择

“View”功能键或在EViews菜单栏中选择 “View”菜单中的相应功能,就可以在对象窗

口的各种视图之间进行切换。对象视图的改变并不会改变对象本身,且对象所包含的数据

也不会变,只是所显示的形式改变了。
视图是一些图表,它提供了一种特殊方式来表示对象。大多数对象都有不止一个视图。

例如,序列对象有表单视图 (SpreadSheet,用于查看原始数据)、曲线图 (Line)、柱状图

(Bar)和直方图 (Histogram)等,序列对象的其他视图还包括分布散点图 (Scatter)、和核密

度图 (KernelDensityGraph)。方程对象有显示视图 (RepresentationView)用来显示方程的

说明,输出视图 (OutputView)用来显示估计结果,实际拟合残差视图 (Actual fitted
residualView)用来显示拟合值与残差值的分布,方差视图 (CovarianceView)显示估计参数

的协方差矩阵和对各种参数检验的说明。

③对象的过程。许多EViews对象还包括过程 (Procedure)。选取过程时,只要在对象窗

口的工具栏中选择Proc功能键或在EViews菜单栏中选择Proc菜单中的相应功能就可以了。
大多数过程的结果在对象窗口中都显示为图表,但与视图不同的是,过程会改变对象

本身的数据或其他对象的数据。许多过程会建立一个或多个新的对象。例如:对一个序列

进行指数平滑时,会产生一个平滑后的新序列。

2.3 基 本 操 作

本节主要介绍三个方面的内容:工作文件、数据库和一般对象的操作。前两部分涉及

前面提到的 “对象容器”,最后一部分给出了对于放在工作文件或数据库中的对象所进行的

基本操作。EViews软件的操作基础是数据,在数据读入软件之前,应对数据进行合理处理

以符合EViews软件的操作需要,数据一般以Excel或ASCII格式保存,但实际使用中多

使用Excel数据。

2.3.1 建立新工作文件

Eviews要求数据的分析处理过程必须在特定的工作文件 (Workfile)中进行,工作文

件 (Workfile)在创建和打开之后便一直保存在内存中,这使得对工作文件中的对象进行

存取的速度更快。所以在录入和分析数据之前,应创建一个工作文件。每个工作文件都具

有特定的样本数据频率 (frequency)和范围 (range)。
打开EViews软件,选择 “File”→ “New”→ “Workfile”,或者在命令窗口中键入命

令:“CREATE”,出现对话框对话框如图2 4所示。
“WorkfileCreate”对话框中共有3个选项区,分别是工作文件结构类型 (Workfile

structuretype)、日期设定 (Datespecification)、命名 (Workfulenames)。
对话框左侧的工作文件结构类型选项区是一个下拉列表框,它用来描述数据集合的基
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本结构:非结构/非时间 (Unstructured/Undated)、时间序列 (Dated regularfrequency)
数据、平衡面板 (Balancedpanel)数据,如图2 5所示。

图2 4 “WorkfileCreate”对话框

图2 5 “Workfilestructuretype”下拉列表框

1.描述具有固定频率的时间序列工作文件

固定频率数据被特定的频率定义而具有固定的间隔 (如年度、季度数据);反之,非固定

频率的数据并没有固定的间隔。在默认状态 “Dated regularfrequency” (时序的)类型下,
可以通过位于图2 4窗口右上部的 “Datespecification”(日期设定)中的 “Frequency”(频
率)选择框中选择数据的性质。较早版本EViews中只有8种类型可供选择,而EViews8增

加了新的数据类型,将用户的选择范围扩大到14种,分别如下。

Multi year多年间隔,可以设置为2年、3年、4年、5年、6年、7年、8年、9
年、10年或20年。

Annual用4位数表示年度,如1980、1999、2004等。 “StartDate”后输入起始年

份,“EndDate”后输入终止年份。如果只有两位数,那么系统将默认为20世纪的年份,
如97默认为1997。注意:EViews无法识别公元100年以前的年份。

Semi annual数据频率为半年,表示为 “年:上半年”或 “年.上半年”。如起始日

期为2001年下半年,结束日期为2005年上半年,那么表示为在 “StartDate”后输入

2001:2 (或2001.2),在 “EndDate”后输入2005:1 (2005.1)。注意年后面只能跟1、

2,分别代表上下半年。

Quarterly数据频率为季度,表示为 “年:季度”或 “年.季度”。具体输入同上。如

2001:1表示2001年第一季度。注意年后面只能跟1、2、3、4,分别代表四个季度。
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Monthly数据频率为月度,表示为 “年:月度”或 “年.月度”。如2002:12、2003:

07。同样,如果输入数据为 “12/6/1990”和 “4/7/2000”则EViews将自动识别恰好包括

该段时间的月份。

Bimonthly数据频率为双月度。

Fortnight数据频率为双周。

Ten day (Trimonthly)数据频率为间隔10天。

Weekly数据频率为周,表示为 “月/日/年”。在输入起止时间以后,系统将会自动

地将时间调整为相隔7天的整周时间。注意:EViews软件默认的时间表示方式为 “月/日/
年”,例如 “9/10/97”表示1997年9月10日。

Daily 5dayweek数据频率为日,表示为 “月/日/年”,即一周5天工作日,系统将

自动生成每周5天的时间序列。如10/22/2003表示2003年10月22日。

Daily 7dayweek数据频率为日,表示为 “月/日/年”,即一周7天工作日,系统将

自动生成每周7天的时间序列。

Daily customweek数据频率为日,表示为 “月/日/年”,即一周任意天数 (1~7)
工作日,系统将自动生成每周任意天数的时间序列。

Integerdate该序列是一个比较特殊的序列,由简单的列举产生,其支持任何整数,
并可以识别100以内的数字。

Intraday如果选择日内频率,则提供有关观察日结构的其他信息,如一天内观测频

率、一周内观测数据的天数、时间以及一天内观测的时间范围的信息。
创建时间序列工作文件步骤:首先,用户选择频率时要根据EViews支持的数据频率

正确设置数据观测值的间隔,以便EViews使用可用的日历信息组织管理数据。例如,有

些年份有53个星期,有些年份有366天,EViews在使用这些数据工作时将会参考相关的

日历信息。其次,用户在 “Startdate”(起始期)和 “Enddate”(终止期)输入数据,点

击 “OK”按钮,EViews会创造一个具有固定频率的工作文件。
以上介绍的是用菜单方式建立工作文件的方法,在 EViews命令窗口键入命令:

“CREATE数据频率 起始期 终止期”,也可实现建立工作文件的方法。其中,数据频率类

型分别为A年度、S半年度、Q季度、M 月度、W 星期、H 小时、MIN分钟、SEC秒、

U非时间序列或不规则数据。
例如,要创建一个年度工作文件,它起始于1980年,终止于2008年。具体操作步骤如下:

①在 “WorkfileCreate”对话框中的工作文件结构类型 (Workfilestructuretype)下

拉列表框选择时间序列 (Dated regularfrequency)数据;

②在日期设定 (Datespecification)中的 “Frequency”(频率)选择框中选择 “Annu-
al”,在 “Startdate” (起始期)和 “Enddate” (终止期)分别输入 “1980”和 “2008”,
点击 “OK”按钮,便可以看到下面工作文件窗口,如图2 6所示。或者在EViews命令

窗口键入命令:createa19802008,回车即可。
在这里,建立了一个工作文件,它包含从1980年到2008年的数据。因为没有估计方

程,所以不存在缺省方程 (DefaultEquation)。工作文件最初只包含两个对象,一个是截

距项c,另一个是残差序列resid。
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图2 6 “Datespecification”工作文件窗口

2.描述非结构工作文件

非结构化数据可以是文本的也可以是非文本的,它使用默认整数标识符的数据。如果

数据不是带日期的常规频率或平衡面板数据,则应选择非结构化类型。创建非结构工作文

件步骤:在对话框左侧工作文件结构类型选项区的下拉列表框中,选择 “Unstructured/

Undated”(非结构/非时间)类型, “Datespecification”将变为 “Datarange” (取值范

围)。在 “Observations”(观测值)的右侧空白框输入个数,输好后点击 “OK”按钮,如

图2 7所示。例如,用户在 “Observations”右侧空白框中输入200,EViews会创建一个

具有200个观测值的工作文件。

图2 7 新建非结构工作文件

3.描述平衡面板工作文件

“Balancedpanel”(平衡面板)提供常规频率面板数据结构的简单方法。面板数据是一

个术语,是描述时间序列数据和截面数据相结合的数据。创建一个平衡面板结构时,要注

意每个截面成员具有相同日期和频率的观测值。创建平衡面板工作文件步骤:在对话框左

侧工作文件结构类型选项区的下拉列表框中,选择 “Balancedpanel”类型,“Datespecifi-
cation”将变为 “Panelspecification” (面板规格),如图2 8所示。选择数据频率 (Fre-
quency),在 “Startdate”右侧空白框输入起始日期,“Enddate”右侧空白框输入终止日

期,在 “Numberofcrosssections”输入截面个数用以构造平衡面板数据。在右下角
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“Workfilenames(optional)”的 “WF”中输入当前创建的工作文件的名称, “Page”中

输入当前文件的当前工作页面的名称。(该步骤为可选,如果现在不输入也可以在保存时输

入)。点击 “OK”按钮,工作文件创建完毕,工作文件窗口同时打开。

图2 8 新建平衡面板工作文件

4.多页工作文件

许多工作文件可能不只涉及单个页面,故把数据组织成多个工作文件页也是非常有用

的。在必须要用多个数据集合工作时的情况下,多页工作文件应用显得尤为重要。例如,
需要分析月度数据和季度数据时,多页工作文件允许在当前的频率下容纳上述两个设置,
如果必要的话,执行自动频率转换。在这种形式下把数据组织起来,允许在季度和月度频

率之间快速切换,从而完成分析任务。这里只介绍一种方法来创建工作文件页,即通过描

述其结构来创建工作文件页。在新建的工作文件窗口中单击窗口底端的 “NewPage”标

签,如图2 9所示,在弹出的快捷菜单中选择 “SpecifybyFrequency/Range”,此时屏幕

上将弹出一个类似于 “WorkfileCreate”的对话框,像描述一个新的工作文件一样,简单

地描述这个工作文件页的结构,并点击 “OK”按钮,EViews将创建一个带有特定结构的

新的工作文件页,它将作为活动工作文件页被系统自动命名。

图2 9 点击 “NewPage”标签弹出快捷菜单
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2.3.2 对象操作基础

1.建立对象

在创建新的对象之前必须打开一个工作文件并将该工作文件窗口置为当前窗口,然后

从主菜单上选择 “Object”→ “NewObject”,如图2 10所示。

图2 10 “NewObject”对话框

在 “Typeofobject”中选择新建对象的类型,在 “Nameforobject”文本框中输入对象名

称,点击 “OK”按钮。例如,如果选择 “Series”,然后点击 “OK”按钮,可以看到一个对

象窗口 (序列窗口),它将显示一个 “UNTTLED”序列的数据表单视图;选择 “Equation”,
将会弹出 “EquationSpecification”对话框,它要求输入更详细的方程设定信息。

对象窗口。当通过双击打开一个对象时,该对象的窗口即被显示在屏幕上。对象窗的

显示内容可能是对象的视图,也可能是对象过程的结果。例如,从主菜单上选择 “Object”

→ “NewObject”→ “Series”,命名为Y,双击工作文件窗口中序列Y的图标打开序列Y
的窗口,如图图2 11所示。

图2 11 典型的对象窗口

这是一个典型的对象窗口,具体体现在:第一,这是标准的 Windows窗口;第二,从

对象窗口的标题栏能够辨认出对象的类型、对象的名称和工作文件的名称;第三,在窗口

标题栏的下方有一个包含多个按钮的工具栏。此外,一些常用的功能键含义如下。
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Print(打印):可以用来打印当前对象的视图;

Properties(属性):提供更改序列的默认列宽和对正方式,并从使用不同显示类型显

示数据的数字显示格式的大列表中进行选择;

Name(命名):允许命名或更改对象的名称;

Freeze(冻结):可以以当前视图为冻结建立新的图形对象、表格对象或文本对象,
这样原序列发生变化时,新的图形或表格对象将不再发生变化,即便是关闭或删除元数据,
被冻结的对象仍然被保留在工作文件中;

Default(预设):该下拉菜单提供一些常见的数据处理;

Edit+/- (编辑):可以在是否编辑当前序列两种模式之间切换;

Samp+/- (样本):可以在显示工作文件时间范围内全部数据和只显示样本数据

(样本期可以为工作文件时间范围的一个子区间)之间切换;

Label+/- (标签):在是否显示对象标签两种模式之间切换;

Wide+/- (宽度):用户可以在宽显示 (如图所示)和窄显示 (单列)之间切换显示。

2.命名对象

EViews通过对象的名称来管理对象及其窗口。如果不给对象命名,系统会自动标注为

“未命名”(UNTITLED)。当操作结束时,EViews会弹出对话框,询问是否保留未命名的

对象。如果选择不保留,该对象将不被保存;如果选择保留,系统将要求对其命名。注意:
每次保存工作文件时,只能保存工作文件中所有已命名的对象,所以用户必须在操作之后

对需要保存并且未命名的对象进行命名。
要给对象命名,可以点击该对象窗口工具栏中的 “Name”,或选择工具栏中的 “Ob-

jects”→ “Name”,也可直接选择EViews主菜单中的 “Objects”→ “Name”功能;然后

在弹出的对话框中输入名称,点击 “OK”按钮即可。
对时间序列或其他对象命名应不超过16个字符。下列名称具有特殊意义,不能作为序

列名 称:ABS、ACOS、AR、ASIN、C、CON、CNORM、COEF、COS、D、DLOG、

DNORM、ELSE、ENDIF、EXP、LOG、LOGIT、LPT1、LPT2、MA、NA、NRND、

PDL、RESID、RND、SAR、SIN、SMA、SQR和THEN。
另外,给序列和其他对象命名时,EViews不区分大小写字母。但为了避免混淆,即使

键入了小写字母,EViews也会把名称中的每一字符都视为大写字母来对待。在EViews显

示工作文件的对象目录时,可以在工作文件的工具栏中选择 “View”→ “NameDisplay”
以指定究竟使用大写字母 (Uppercase)还是小写字母 (Lowercase)。

3.复制、冻结及批注对象

复制对象可以采用以下两种方式:一种是点击 “Objects”→ “Copy”键,此时原来的

对象会完全被复制下来。除名称之外,该拷贝与原来的对象完全相同。第二种是点击对象

工具栏上的 “Objects”→ “FreezeOutput”,此时可建立原始对象当前视图的表格或图形。
复制对象的优点是新对象能够将原对象的所有特点都复制下来。新对象包括了原对象所有

的视图和过程,并且可以像原对象一样被用于以后的分析。
冻结对象是复制对象的视图。冻结对象后,原窗口的上方将打开一个新对象窗口。如

果改变原对象,被冻结的对象不会发生改变。冻结对象的优点是可以对由 “Freeze”建立

的表格和图形进行多种形式的编辑以供演示和报告之用。而且,如果工作文件的样本或数

据发生变化,冻结的视图不会有任何改变。

—52—



EViews对象提供了批注功能,用户可以在当前信息的下面添加附加信息来对批注进行补

充,这些批注显示在对象批注视图中。EViews在批注中自动提供对象最后一次被更新的信息。

4.保存、调用和更新对象

(1)保存对象。EViews中的对象都必须在工作文件中进行操作。因此,使用EViews
时,首先要建立或打开一个工作文件,对象将出现在工作文件中,对象的名称将出现在工

作文件窗口的目录中,当工作文件存盘时,对象将作为工作文件的一部分被保存。
另外,对象还可以直接保存到磁盘。通过点击工作文件窗口工具栏中的 “Objects”→

“StoretoDB”,将弹出 “Store”对话框,如图2 12所示,可以将选定的对象保存到数据

库中,将对象作为一个独立的文件直接保存到磁盘中。

图2 12 “Store”对话框

(2)调用对象。依次选择工作文件窗口工具栏中的 “Objects”→ “FetchfromDB”,
在弹出的 “Fetch”对话框 (见图2 13)中指定路径、类型和名称,点击 “OK”按钮,便

可将选定的对象加载到当前工作文件中。注意,选择调用对象将同时获取组定义和实际序

列,并将获取组定义及其序列作为单独的对象。

图2 13 “Fetch”对话框

(3)更新对象。更新工作类似于获取对象,但要求对象存在于工作文件中。先选中需

要更新的对象,再利用对象窗口工具栏中的 “Objects”→ “UpdatefromDB”,从对象文

件或数据库中提取已经储存的对象来更新替换当前对象。

2.3.3 数据的输入

数据的输入方式主要有4种,以下分别予以介绍。
(1)以菜单方式———单个序列方式输入数据。在EViews窗口或工作文件窗口中点击

“Object”®“Newobject”,则会弹出下面窗口,如图2 14所示。

—62—



图2 14 创建序列对象

在 “TypeofObject”中选择 “Series”类型,在 “NameforObject”中输入序列名称

X,点击 “OK”按钮,则回到workfile界面,双击X序列,则打开数据编辑窗口。点击

Edit+/-打开数据编辑状态,(用户可以根据习惯点击Smpl+/-改变数据按行或列的显

示形式,)然后输入数据 (与Excel类似),如图2 15所示。

图2 15 数据的输入

图2 15中①处是指数据存在的方式,可以是原始数据状态,也可以是一阶差分、对数等。
(2)以菜单方式———群组方式输入数据。在EViews窗口中点击 “Quick”®“Empty

Group (EditSeries)”,则会进入数据编辑窗口,如图2 16所示。

图2 16 数据编辑窗口
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先把右侧红框中光标往上移到顶,下侧红框中的光标往左移到顶,在空出的行中输入

序列名X,按下回车键,则弹出窗口,如图2 17所示,选择所建立数据类型。

图2 17 选择建立数据类型

图2 17中,Numericseries是数字型序列,缺失数据为NA;Numericseriescontai-
ningdates是日期型序列;Alphaseries是字符型序列,比如姓名、地址等。

在Group中可以输入多个序列。输入序列名后,可以输入数据 (或直接从Excel拷贝

数据),如图2 18所示。

图2 18 在Group中输入序列

图2 18中的①UNTITLED:表示没有给Group命名。点击Group中的Name菜单,
则出现如图2 19的对话框。

图2 19 “ObjectName”对话框

在Nametoidentifyobject中输入名称urban或可以默认group01,在下面的 “Display
name”中可输入注释,也可不输入,点击 “OK”按钮后,在workfile中就会出现名为urban
的group了。不仅如此,存在group中的序列也会以Series的形式存在workfile中。

如果想修改序列名,有如下两种方法。
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【第一种】在Group中直接点击序列名,然后输入用户自己建立的序列名,按回车键

即可。
【第二种】在workfile中:选中序列,如X,按右键,在快捷菜单中选Rename…;或

点击 “Object”®“RenameSelected”,则会弹出ObjectName窗口,在Name选项中输入

新的名称,点击 “OK”按钮。
(3)以命令行方式———data命令输入数据。命令格式为

DATA <序列名1><序列名2>… <序列名n>
回车后弹出的数据编辑框与第2种输入方式完全相同。
(4)以命令行方式———Series命令输入数据。命令格式为

SERIES 序列名 或 SERIES 序列名=公式

回车后,数据输入方式与第1种方法完全相同。
此外,EViews可以自动生成一个数值为整数的时间序列。在创建工作文件之后,可以

在命令窗口中键入命令

SERIEST=@TREND (时间)
生成一个以该时间为0基准的整数的时间序列。例如在命令窗口中键入命令 “SERIES

T=@TREND (1990)”,就将自动生成一个以1990年为数值0的整数时间序列。
上面介绍的数据输入方式都是通过键盘实现的。EViews也支持直接从各种格式的外部

文件输入数据。例如Excel形式的数据,所输入的数据应预先在Excel表格中编辑好,此时

Excel表格的第一行和第一列应为空白,以便EViews软件读取时第一行和第一列被默认为

序列名称和行名称。注意:在导入数据时如果出现字符,EViews程序将无法读入,系统将

默认为N/A。如果工作文件的区间大于导入数据的区间,系统将自动导入全部数据,同时

超出导入数据区间的部分,系统将默认为 N/A;如果工作文件的区间小于导入数据的区

间,系统将自动取导入数据区间中最前面的数据导入工作文件。

2.3.4 保存工作文件

在工具栏中点击 “Save”按钮,EViews将首先弹出保存位置,选择想保存的位置后,

EViews将弹出 “WorkfileSave”对话框。
工作文件的存储主要有两种方式:一种是在主窗口中选择 “File”→ “Save”或 “Save

As”,另一种是在工作文件窗口工具栏中单击 “Save”按钮,如图2 20所示。

图2 20 “WorkfileSave”对话框

在 “Seriesstorage”选项中,选择 “Singleprecision”为保存单精度序列数据,该方式保

存的数据精度相对较低,但是保存的文件所占空间容量较小;选择 “Doubleprecision”为保存

双精度数据,该方式保存的数据精度相对较,高但文件相对较大;“Usecompression”为压缩
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形式保存数据,如果勾选 “Usecompression”,EViews将会分析序列内容,为每个序列选择

一个最佳的储存精度,应用压缩算法,缩小工作文件的大小。
在这个对话框最下方还有一个复选框 “PromptoneachSave”,用来控制是否显示

“WorkfileSave”对话框。默认状态下,每次保存工作文件都将显示这个对话框。如果不勾选

这个复选框,EViews在以后的保存操作中将隐藏这个对话框。如果以后希望改变这里的保存

设置或希望显示这个对话框,必须在主菜单中依次选择 “Options”→ “GeneralOptions”→
“Datastorage”,在弹出的 “WorkfileSave”对话框中更新有关设定,如图2 21所示。

图2 21 “GeneralOptions”对话框
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(1)EViews采用了与对象、对象的属性和对象的操作方法等类似的概念来描述数

据、数据表现形式和数据操作,EViews中的所有数据信息都存储在对象中,对数据的

操作都可以通过查看其属性或使用其操作方法来实现。EViews中与对象相关的概念有

对象容器、对象类型。
(2)对象容器是用于保存和组织对象的,所有对象都必须存放在对象容器中,对象

容器本身也是一个对象。EViews的对象容器有工作文件 (Workfile)和数据库 (Data-
base)两种。

(3)工作文件是最重要的对象容器,任何经济计量分析的第一步都是创建一个新工

作文件或者打开已存在的工作文件。工作文件创建或打开后便一直保存在内存之中,这

使得对工作文件中的对象进行存取的速度更快。工作文件有两个基本特点:一是打开后

即被调入内存中,以便快速地获得其中的对象;二是工作文件都有频率和范围。
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(4)数据库与工作文件不同,当存取数据库中的对象时,可以直接对保存在磁盘上

的数据库对象进行存取,而无须把整个数据库装载到内存中。数据库中的对象可以有不

同的数据频率和范围。数据库支持强大的查询功能,适用于管理大量数据。
(5)EViews对象用于保存经济计量分析的信息。根据分析目的不同,可分别使用

不同类型的对象。根据保存信息的不同,对象类型可分为数据对象和非数据对象。
(6)视图以表格和图形窗口的形式提供了查看和分析对象中数据的各种方法。除标

量对象外,其他对象都具有视图。视图相当于一般对象的可视化属性,EViews对象具

有多个属性,因而具有多个视图。
(7)过程相当于一般对象的操作方法,它与视图相同的地方是,经常在对象窗口中

显示表格或图形;与视图不同的是,过程会改变对象本身的数据,有的过程甚至可以创

建新的对象,而视图则不可以。
(8)对象操作基础主要包括:建立对象、命名对象、更新对象复制、冻结及批注对

象、保存对象、调用和更新对象。
(9)数据的输入主要有单个序列方式输入、群组方式输入、data命令方式输入和

series命令方式输入。此外,EViews可以自动生成一个数值为整数的时间序列。
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